about summary refs log tree commit diff
path: root/tvix/tools/weave/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/tools/weave/Cargo.toml')
-rw-r--r--tvix/tools/weave/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/tvix/tools/weave/Cargo.toml b/tvix/tools/weave/Cargo.toml
new file mode 100644
index 0000000000..7c6c2d2f0c
--- /dev/null
+++ b/tvix/tools/weave/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "weave"
+version = "0.1.0"
+edition = "2021"
+
+[workspace]
+members = ["."]
+
+# TODO(edef): cut down on required features, this is kind of a grab bag right now
+[dependencies]
+anyhow = { version = "1.0.79", features = ["backtrace"] }
+hashbrown = "0.14.3"
+nix-compat = { version = "0.1.0", path = "../../nix-compat" }
+owning_ref = "0.4.1"
+rayon = "1.8.1"
+tokio = { version = "1.36.0", features = ["full"] }
+
+[dependencies.polars]
+version = "0.36.2"
+features = ["parquet"]