about summary refs log tree commit diff
path: root/tvix/tools/narinfo2parquet/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/tools/narinfo2parquet/Cargo.toml')
-rw-r--r--tvix/tools/narinfo2parquet/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/tvix/tools/narinfo2parquet/Cargo.toml b/tvix/tools/narinfo2parquet/Cargo.toml
new file mode 100644
index 0000000000..3efa9d1df9
--- /dev/null
+++ b/tvix/tools/narinfo2parquet/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "narinfo2parquet"
+version = "0.1.0"
+edition = "2021"
+
+# We can't join the //tvix workspace, because that locks zstd
+# at an ancient version, which is incompatible with polars
+[workspace]
+members = ["."]
+
+[dependencies]
+anyhow = { version = "1.0.75", features = ["backtrace"] }
+jemallocator = "0.5.4"
+nix-compat = { version = "0.1.0", path = "../../nix-compat" }
+tempfile-fast = "0.3.4"
+zstd = "0.13.0"
+
+[dependencies.polars]
+version = "0.36.2"
+default-features = false
+features = [
+    "parquet",
+    "polars-io",
+    "dtype-categorical"
+]