about summary refs log tree commit diff
path: root/tvix/tools/crunch-v2/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/tools/crunch-v2/default.nix')
-rw-r--r--tvix/tools/crunch-v2/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tvix/tools/crunch-v2/default.nix b/tvix/tools/crunch-v2/default.nix
new file mode 100644
index 0000000000..689e86be65
--- /dev/null
+++ b/tvix/tools/crunch-v2/default.nix
@@ -0,0 +1,15 @@
+{ pkgs, ... }:
+
+let
+  crates = import ./Cargo.nix {
+    inherit pkgs;
+    nixpkgs = pkgs.path;
+
+    defaultCrateOverrides = pkgs.defaultCrateOverrides // {
+      crunch-v2 = prev: {
+        nativeBuildInputs = (prev.nativeBuildInputs or [ ]) ++ [ pkgs.buildPackages.protobuf ];
+      };
+    };
+  };
+in
+crates.rootCrate.build