about summary refs log tree commit diff
path: root/tvix/proto/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/proto/default.nix')
-rw-r--r--tvix/proto/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/tvix/proto/default.nix b/tvix/proto/default.nix
new file mode 100644
index 0000000000..7ff03ba3b7
--- /dev/null
+++ b/tvix/proto/default.nix
@@ -0,0 +1,9 @@
+# Build protocol buffer definitions to ensure that protos are valid in
+# CI. Note that the output of this build target is not actually used
+# anywhere, it just functions as a CI check for now.
+{ pkgs, ... }:
+
+pkgs.runCommandNoCC "tvix-cc-proto" {} ''
+  mkdir $out
+  ${pkgs.protobuf}/bin/protoc -I ${./.} evaluator.proto --cpp_out=$out
+''