about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml56
1 files changed, 56 insertions, 0 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
new file mode 100644
index 0000000000..876ac3ecad
--- /dev/null
+++ b/tvix/nix-compat/Cargo.toml
@@ -0,0 +1,56 @@
+[package]
+name = "nix-compat"
+version = "0.1.0"
+edition = "2021"
+
+[features]
+# async NAR writer
+async = ["tokio"]
+# code emitting low-level packets used in the daemon protocol.
+wire = ["tokio", "pin-project-lite"]
+
+# Enable all features by default.
+default = ["async", "wire"]
+
+[dependencies]
+bitflags = "2.4.1"
+bstr = { version = "1.6.0", features = ["alloc", "unicode", "serde"] }
+data-encoding = "2.3.3"
+ed25519 = "2.2.3"
+ed25519-dalek = "2.1.0"
+enum-primitive-derive = "0.3.0"
+glob = "0.3.0"
+nom = "7.1.3"
+num-traits = "0.2.18"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+sha2 = "0.10.6"
+thiserror = "1.0.38"
+
+[dependencies.tokio]
+optional = true
+version = "1.32.0"
+features = ["io-util", "macros"]
+
+[dependencies.pin-project-lite]
+optional = true
+version = "0.2.13"
+
+[dev-dependencies]
+criterion = { version = "0.5", features = ["html_reports"] }
+futures = { version = "0.3.30", default-features = false, features = ["executor"] }
+hex-literal = "0.4.1"
+lazy_static = "1.4.0"
+pretty_assertions = "1.4.0"
+rstest = "0.19.0"
+serde_json = "1.0"
+tokio-test = "0.4.3"
+zstd = "^0.13.0"
+
+[[bench]]
+name = "derivation_parse_aterm"
+harness = false
+
+[[bench]]
+name = "narinfo_parse"
+harness = false