about summary refs log tree commit diff
path: root/tvix/nar-bridge/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/nar-bridge/default.nix')
-rw-r--r--tvix/nar-bridge/default.nix19
1 files changed, 10 insertions, 9 deletions
diff --git a/tvix/nar-bridge/default.nix b/tvix/nar-bridge/default.nix
index c0247f279f32..2f1384e8211f 100644
--- a/tvix/nar-bridge/default.nix
+++ b/tvix/nar-bridge/default.nix
@@ -1,10 +1,11 @@
-# Target containing just the proto files.
+{ depot, lib, ... }:
 
-{ depot, pkgs, lib, ... }:
-
-pkgs.buildGoModule {
-  name = "nar-bridge";
-  src = depot.third_party.gitignoreSource ./.;
-
-  vendorHash = "sha256-7jugbC5sEGhppjiZgnoLP5A6kQSaHK9vE6cXVZBG22s=";
-}
+(depot.tvix.crates.workspaceMembers.nar-bridge.build.override {
+  runTests = true;
+}).overrideAttrs (old: rec {
+  meta.ci.targets = lib.filter (x: lib.hasPrefix "with-features" x || x == "no-features") (lib.attrNames passthru);
+  passthru = old.passthru // (depot.tvix.utils.mkFeaturePowerset {
+    inherit (old) crateName;
+    features = [ "otlp" ];
+  });
+})