about summary refs log tree commit diff
path: root/tvix/glue/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/glue/Cargo.toml')
-rw-r--r--tvix/glue/Cargo.toml57
1 files changed, 57 insertions, 0 deletions
diff --git a/tvix/glue/Cargo.toml b/tvix/glue/Cargo.toml
new file mode 100644
index 0000000000..f929d720a0
--- /dev/null
+++ b/tvix/glue/Cargo.toml
@@ -0,0 +1,57 @@
+[package]
+name = "tvix-glue"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+async-recursion = "1.0.5"
+bstr = "1.6.0"
+bytes = "1.4.0"
+data-encoding = "2.3.3"
+futures = "0.3.30"
+magic = "0.16.2"
+nix-compat = { path = "../nix-compat" }
+pin-project = "1.1"
+reqwest = { version = "0.11.22", features = ["rustls-tls-native-roots"], default-features = false }
+tvix-build = { path = "../build", default-features = false, features = []}
+tvix-eval = { path = "../eval" }
+tvix-castore = { path = "../castore" }
+tvix-store = { path = "../store", default-features = false, features = []}
+tracing = "0.1.37"
+tokio = "1.28.0"
+tokio-tar = "0.3.1"
+tokio-util = { version = "0.7.9", features = ["io", "io-util", "compat"] }
+thiserror = "1.0.38"
+serde = "1.0.195"
+serde_json = "1.0"
+sha2 = "0.10.8"
+sha1 = "0.10.6"
+md-5 = "0.10.6"
+url = "2.4.0"
+walkdir = "2.4.0"
+
+[dependencies.async-compression]
+version = "0.4.6"
+features = ["tokio", "gzip", "bzip2", "xz"]
+
+[dependencies.wu-manber]
+git = "https://github.com/tvlfyi/wu-manber.git"
+
+[dev-dependencies]
+criterion = { version = "0.5", features = ["html_reports"] }
+hex-literal = "0.4.1"
+lazy_static = "1.4.0"
+nix = { version = "0.27.1", features = [ "fs" ] }
+pretty_assertions = "1.4.0"
+rstest = "0.19.0"
+tempfile = "3.8.1"
+
+[features]
+default = ["nix_tests"]
+# Enables running the Nix language test suite from the original C++
+# Nix implementation (at version 2.3) against Tvix.
+nix_tests = []
+
+[[bench]]
+name = "eval"
+harness = false