about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-thunked-if.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-thunked-if.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-thunked-if.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-thunked-if.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-thunked-if.nix
new file mode 100644
index 0000000000..3810ebe784
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-thunked-if.nix
@@ -0,0 +1,8 @@
+let
+  a = { };
+in
+let
+  c = if builtins.isFunction a then a b else a;
+  b = { };
+in
+c