about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-fix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-fix.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-fix.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-fix.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-fix.nix
new file mode 100644
index 0000000000..6069950194
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-fix.nix
@@ -0,0 +1,8 @@
+let
+  fix = f: let x = f x; in x;
+in
+fix (self: {
+  a = 1;
+  b = self.a + 20;
+  c = self.b * 2;
+})