about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-genericClosure-pointer-equality.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-builtins-genericClosure-pointer-equality.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-builtins-genericClosure-pointer-equality.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-genericClosure-pointer-equality.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-genericClosure-pointer-equality.nix
index 5e662cdaf7..f6ca340c09 100644
--- a/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-genericClosure-pointer-equality.nix
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-genericClosure-pointer-equality.nix
@@ -3,13 +3,13 @@ let
 in
 
 # key needs to be a list since it uses comparison, not equality checks:
-# lists are comparable in Nix if all non-comparable items in them are equal (e.g.
-# functions, attribute sets).
+  # lists are comparable in Nix if all non-comparable items in them are equal (e.g.
+  # functions, attribute sets).
 builtins.genericClosure {
   startSet = [
-    { key = [ { inherit foo; } ]; val = null; }
+    { key = [{ inherit foo; }]; val = null; }
   ];
-  operator = { val, ... }: if val != null then [] else [
-    { key = [ { inherit foo; } ]; val = throw "no pointer equality? πŸ₯ΊπŸ‘‰πŸ‘ˆ"; }
+  operator = { val, ... }: if val != null then [ ] else [
+    { key = [{ inherit foo; }]; val = throw "no pointer equality? πŸ₯ΊπŸ‘‰πŸ‘ˆ"; }
   ];
 }