about summary refs log tree commit diff
path: root/tvix/eval/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/default.nix')
-rw-r--r--tvix/eval/default.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/tvix/eval/default.nix b/tvix/eval/default.nix
index e50ac32be4..91661291f7 100644
--- a/tvix/eval/default.nix
+++ b/tvix/eval/default.nix
@@ -1,5 +1,9 @@
-{ depot, ... }:
+# TODO: find a way to build the benchmarks via crate2nix
+{ depot, pkgs, ... }:
 
-depot.third_party.naersk.buildPackage {
-  src = ./.;
+depot.tvix.crates.workspaceMembers.tvix-eval.build.override {
+  runTests = true;
+
+  # Make C++ Nix available, to compare eval results against.
+  testInputs = [ pkgs.nix ];
 }