about summary refs log tree commit diff
path: root/tvix/eval/builtin-macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/builtin-macros/Cargo.toml')
-rw-r--r--tvix/eval/builtin-macros/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/tvix/eval/builtin-macros/Cargo.toml b/tvix/eval/builtin-macros/Cargo.toml
new file mode 100644
index 0000000000..3a35ea12a0
--- /dev/null
+++ b/tvix/eval/builtin-macros/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "tvix-eval-builtin-macros"
+version = "0.0.1"
+authors = [ "Griffin Smith <root@gws.fyi>" ]
+edition = "2021"
+
+[dependencies]
+syn = { version = "1.0.57", features = ["full", "parsing", "printing", "visit", "visit-mut", "extra-traits"] }
+quote = "1.0.8"
+proc-macro2 = "1"
+
+[lib]
+proc-macro = true
+
+[dev-dependencies]
+tvix-eval = { path = "../" }