about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml14
1 files changed, 13 insertions, 1 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index 4f2fda7e61..226f3a98a3 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -5,9 +5,16 @@ edition = "2021"
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
+[lib]
+name = "tvix_eval"
+
+[[bin]]
+name = "tvix-eval"
+required-features = [ "repl" ]
+
 [dependencies]
 smol_str = "0.1"
-rustyline = "10.0.0"
+rustyline = { version = "10.0.0", optional = true }
 dirs = "4.0.0"
 path-clean = "0.1"
 tabwriter = { version = "1.2", optional = true }
@@ -27,10 +34,15 @@ pretty_assertions = "1.2.1"
 itertools = "0.10.3"
 
 [features]
+default = [ "repl" ]
+
 # Enables running the Nix language test suite from the original C++
 # Nix implementation (at version 2.3) against Tvix.
 nix_tests = []
 
+# Enables building the binary (tvix-eval REPL)
+repl = [ "dep:rustyline" ]
+
 # Enables printing compiled code and tracing the stack state at runtime.
 disassembler = ["dep:tabwriter"]