about summary refs log tree commit diff
path: root/tvix/cli/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/cli/Cargo.toml')
-rw-r--r--tvix/cli/Cargo.toml34
1 files changed, 20 insertions, 14 deletions
diff --git a/tvix/cli/Cargo.toml b/tvix/cli/Cargo.toml
index d15165383b9e..d13cd17cbd0e 100644
--- a/tvix/cli/Cargo.toml
+++ b/tvix/cli/Cargo.toml
@@ -8,23 +8,29 @@ name = "tvix"
 path = "src/main.rs"
 
 [dependencies]
-nix-compat = { path = "../nix-compat" }
 tvix-build = { path = "../build" }
-tvix-castore = { path = "../castore" }
 tvix-store = { path = "../store", default-features = false, features = []}
 tvix-eval = { path = "../eval" }
 tvix-glue = { path = "../glue" }
-bytes = "1.4.0"
-clap = { version = "4.0", features = ["derive", "env"] }
-dirs = "4.0.0"
-rustyline = "10.0.0"
-thiserror = "1.0.38"
-tokio = "1.28.0"
-tracing = { version = "0.1.37", features = ["max_level_trace", "release_max_level_info"] }
-tracing-subscriber = { version = "0.3.16", features = ["json"] }
-
-[dependencies.wu-manber]
-git = "https://github.com/tvlfyi/wu-manber.git"
+tvix-tracing = { path = "../tracing" }
+bytes = { workspace = true }
+clap = { workspace = true, features = ["derive", "env"] }
+dirs = { workspace = true }
+rustyline = { workspace = true }
+rnix = { workspace = true }
+rowan = { workspace = true }
+smol_str = { workspace = true }
+thiserror = { workspace = true }
+tokio = { workspace = true }
+tracing = { workspace = true }
+tracing-indicatif = { workspace = true }
+rustc-hash = { workspace = true }
+mimalloc = { workspace = true }
+wu-manber = { workspace = true }
 
 [dev-dependencies]
-test-case = "3.3.1"
+expect-test = { workspace = true }
+
+[features]
+default = []
+tracy = ["tvix-tracing/tracy"]