about summary refs log tree commit diff
path: root/tvix/cli/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/cli/Cargo.toml')
-rw-r--r--tvix/cli/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/tvix/cli/Cargo.toml b/tvix/cli/Cargo.toml
new file mode 100644
index 0000000000..ce8d361771
--- /dev/null
+++ b/tvix/cli/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "tvix-cli"
+version = "0.1.0"
+edition = "2021"
+
+[[bin]]
+name = "tvix"
+path = "src/main.rs"
+
+[dependencies]
+nix-compat = { path = "../nix-compat" }
+tvix-build = { path = "../build" }
+tvix-castore = { path = "../castore" }
+tvix-store = { path = "../store", default-features = false, features = []}
+tvix-eval = { path = "../eval" }
+tvix-glue = { path = "../glue" }
+bytes = "1.4.0"
+clap = { version = "4.0", features = ["derive", "env"] }
+dirs = "4.0.0"
+rustyline = "10.0.0"
+thiserror = "1.0.38"
+tokio = "1.28.0"
+tracing = { version = "0.1.37", features = ["max_level_trace", "release_max_level_info"] }
+tracing-subscriber = { version = "0.3.16", features = ["json"] }
+
+[dependencies.wu-manber]
+git = "https://github.com/tvlfyi/wu-manber.git"