about summary refs log tree commit diff
path: root/tvix/castore/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/castore/default.nix')
-rw-r--r--tvix/castore/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tvix/castore/default.nix b/tvix/castore/default.nix
new file mode 100644
index 0000000000..641d883760
--- /dev/null
+++ b/tvix/castore/default.nix
@@ -0,0 +1,23 @@
+{ depot, pkgs, ... }:
+
+(depot.tvix.crates.workspaceMembers.tvix-castore.build.override {
+  runTests = true;
+  testPreRun = ''
+    export SSL_CERT_FILE=${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt;
+  '';
+
+  # enable some optional features.
+  features = [ "default" "cloud" ];
+}).overrideAttrs (_: {
+  meta.ci.targets = [ "integration-tests" ];
+  passthru.integration-tests = depot.tvix.crates.workspaceMembers.tvix-castore.build.override {
+    runTests = true;
+    testPreRun = ''
+      export SSL_CERT_FILE=${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt;
+      export PATH="$PATH:${pkgs.lib.makeBinPath [pkgs.cbtemulator pkgs.google-cloud-bigtable-tool]}"
+    '';
+
+    # enable some optional features.
+    features = [ "default" "cloud" "integration" ];
+  };
+})