about summary refs log tree commit diff
path: root/tvix/build/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/build/Cargo.toml')
-rw-r--r--tvix/build/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/tvix/build/Cargo.toml b/tvix/build/Cargo.toml
new file mode 100644
index 0000000000..626fd35d77
--- /dev/null
+++ b/tvix/build/Cargo.toml
@@ -0,0 +1,33 @@
+[package]
+name = "tvix-build"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+bytes = "1.4.0"
+clap = { version = "4.0", features = ["derive", "env"] }
+itertools = "0.12.0"
+prost = "0.12.1"
+thiserror = "1.0.56"
+tokio = { version = "1.32.0" }
+tokio-listener = { version = "0.3.2", features = [ "tonic011" ] }
+tonic = { version = "0.11.0", features = ["tls", "tls-roots"] }
+tvix-castore = { path = "../castore" }
+tracing = "0.1.37"
+tracing-subscriber = { version = "0.3.16", features = ["json"] }
+url = "2.4.0"
+
+[dependencies.tonic-reflection]
+optional = true
+version = "0.11.0"
+
+[build-dependencies]
+prost-build = "0.12.1"
+tonic-build = "0.11.0"
+
+[features]
+default = []
+tonic-reflection = ["dep:tonic-reflection"]
+
+[dev-dependencies]
+rstest = "0.19.0"