about summary refs log tree commit diff
path: root/tvix/boot/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/boot/default.nix')
-rw-r--r--tvix/boot/default.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/tvix/boot/default.nix b/tvix/boot/default.nix
index 7be05c815cdc..60eb2f1b7608 100644
--- a/tvix/boot/default.nix
+++ b/tvix/boot/default.nix
@@ -1,13 +1,16 @@
-{ depot, pkgs, ... }:
+{ lib, pkgs, ... }:
 
 rec {
   # A binary that sets up /nix/store from virtiofs, lists all store paths, and
   # powers off the machine.
-  tvix-init = depot.nix.buildGo.program {
+  tvix-init = pkgs.buildGoModule rec {
     name = "tvix-init";
-    srcs = [
-      ./tvix-init.go
-    ];
+    src = lib.fileset.toSource {
+      root = ./.;
+      fileset = ./tvix-init.go;
+    };
+    vendorHash = null;
+    postPatch = "go mod init ${name}";
   };
 
   # A kernel with virtiofs support baked in