about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 8a7ce8b344..7c7ad0b6c0 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -11,7 +11,8 @@
 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 # See the License for the specific language governing permissions and
 # limitations under the License.
-{ pkgs ? import <nixpkgs> {} }:
+{ pkgs ? import <nixpkgs> {}
+, preLaunch ? "" }:
 
 with pkgs;
 
@@ -88,6 +89,8 @@ rec {
       mkdir -p /etc/nix
       echo 'sandbox = false' >> /etc/nix/nix.conf
 
+      ${preLaunch}
+
       exec ${nixery-bin}/bin/nixery
     '';
   in dockerTools.buildLayeredImage {