about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 3900353751..696420d0f0 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -15,7 +15,8 @@
 { pkgs ? import ./nixpkgs-pin.nix
 , preLaunch ? ""
 , extraPackages ? []
-, maxLayers ? 20 }:
+, maxLayers ? 20
+, commitHash ? null }@args:
 
 with pkgs;
 
@@ -25,7 +26,7 @@ let
   # Current Nixery commit - this is used as the Nixery version in
   # builds to distinguish errors between deployed versions, see
   # server/logs.go for details.
-  nixery-commit-hash = pkgs.lib.commitIdFromGitRepo ./.git;
+  nixery-commit-hash = args.commitHash or pkgs.lib.commitIdFromGitRepo ./.git;
 
   # Go implementation of the Nixery server which implements the
   # container registry interface.