about summary refs log tree commit diff
path: root/tools/depot-scanner/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/depot-scanner/default.nix')
-rw-r--r--tools/depot-scanner/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/depot-scanner/default.nix b/tools/depot-scanner/default.nix
new file mode 100644
index 0000000000..d18034cff0
--- /dev/null
+++ b/tools/depot-scanner/default.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, ...}:
+
+let
+  localProto = depot.nix.buildGo.grpc {
+    name = "code.tvl.fyi/tools/depot-scanner/proto";
+    proto = ./depot_scanner.proto;
+  };
+in depot.nix.buildGo.program {
+  name = "depot-scanner";
+  srcs = [
+    ./main.go
+  ];
+  deps = [
+    localProto
+  ];
+} // { inherit localProto; }