about summary refs log tree commit diff
path: root/tools/cheddar/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/cheddar/default.nix')
-rw-r--r--tools/cheddar/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tools/cheddar/default.nix b/tools/cheddar/default.nix
index c8d7ba5ffe..d29f75dc3c 100644
--- a/tools/cheddar/default.nix
+++ b/tools/cheddar/default.nix
@@ -3,10 +3,22 @@
 depot.third_party.naersk.buildPackage {
   src = ./.;
   doDoc = false;
+  doCheck = true;
 
   override = x: {
     # Use our custom bat syntax set, which is everything from upstream,
     # plus additional languages we care about.
     BAT_SYNTAXES = "${depot.third_party.bat_syntaxes}";
   };
+
+  passthru = {
+    # Wrapper for cgit which can't be told to pass arguments to a filter
+    about-filter = pkgs.writeShellScriptBin "cheddar-about" ''
+      exec ${depot.tools.cheddar}/bin/cheddar --about-filter $@
+    '';
+  };
+
+  meta.ci.targets = [
+    "about-filter"
+  ];
 }