about summary refs log tree commit diff
path: root/third_party/rust-crates/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust-crates/default.nix')
-rw-r--r--third_party/rust-crates/default.nix64
1 files changed, 31 insertions, 33 deletions
diff --git a/third_party/rust-crates/default.nix b/third_party/rust-crates/default.nix
index 17e06a7049..697e47cdde 100644
--- a/third_party/rust-crates/default.nix
+++ b/third_party/rust-crates/default.nix
@@ -1,9 +1,11 @@
 { depot, pkgs, ... }:
 
 # TVL tool rust crate dependencies, where tools like carnix are not used.
-# Intended for manual updates, which keeps us honest with what we pull into our closure.
+# Intended for manual updates, which makes sure we never actually update.
 
 let
+  inherit (pkgs) fetchpatch;
+
   buildRustCrate =
     attrs@{ edition ? "2018"
     , pname
@@ -16,8 +18,7 @@ let
         ;
     });
 in
-
-rec {
+depot.nix.readTree.drvTargets rec{
   cfg-if = buildRustCrate {
     pname = "cfg-if";
     version = "1.0.0";
@@ -75,15 +76,15 @@ rec {
 
   libc = buildRustCrate {
     pname = "libc";
-    version = "0.2.82";
+    version = "0.2.153";
     edition = "2015";
-    sha256 = "02zgn6c0xwh331hky417lbr29kmvrw3ylxs8822syyhjfjqszvsx";
+    sha256 = "1xz1nz9k0vrv7lbir7ma0q4ii9cp3c0s9fbxp6268film2wrxs19";
   };
 
   bitflags = buildRustCrate {
     pname = "bitflags";
-    version = "1.2.1";
-    sha256 = "0b77awhpn7yaqjjibm69ginfn996azx5vkzfjj39g3wbsqs7mkxg";
+    version = "2.4.2";
+    sha256 = "1p370m8qh3clk33rqmyglcphlsq0gpf69j22d61fy4kkmrfn8hbd";
   };
 
   inotify-sys = buildRustCrate {
@@ -95,9 +96,18 @@ rec {
 
   inotify = buildRustCrate {
     pname = "inotify";
-    version = "0.9.2";
+    version = "0.10.2";
+    patches = [
+      # Unreleased compat patch for bitflags >= 2
+      (fetchpatch {
+        name = "inotify-bitflags-2.patch";
+        url = "https://github.com/hannobraun/inotify-rs/commit/f4765593894ef0b36d39739cf3349485ca88b1ce.patch";
+        sha256 = "107r9jai0jdr0hybsvbjyjn23vyk2lp1l1pmznb7jp38my0grh4b";
+        excludes = [ "Cargo.toml" ];
+      })
+    ];
     dependencies = [ bitflags libc inotify-sys ];
-    sha256 = "0fcknyvknglwwk1pdzdlb4m0ry2dym1yx8r5prf2v00pxnjk0hv2";
+    sha256 = "0lqwk7yf6bzc2jzj5iji2p3f29zdpllqd207vgg7jswmg2gqnlqc";
   };
 
   httparse = buildRustCrate {
@@ -108,7 +118,7 @@ rec {
   };
 
   version-check = buildRustCrate {
-    pname = "version-check";
+    pname = "version_check";
     version = "0.9.2";
     edition = "2015";
     sha256 = "1vwvc1mzwv8ana9jv8z933p2xzgj1533qwwl5zr8mi89azyhq21v";
@@ -168,11 +178,11 @@ rec {
 
   chrono = buildRustCrate {
     pname = "chrono";
-    version = "0.4.19";
-    edition = "2015";
+    version = "0.4.22";
+    edition = "2018";
     dependencies = [ num-traits num-integer ];
     features = [ "alloc" "std" ];
-    sha256 = "0cjf5dnfbk99607vz6n5r6bhwykcypq5psihvk845sxrhnzadsar";
+    sha256 = "01vbn93ba1q2afq10qis41j847damk5ifgn1all337mcscl345fn";
   };
 
   imap-proto = buildRustCrate {
@@ -205,9 +215,9 @@ rec {
 
   epoll = buildRustCrate {
     pname = "epoll";
-    version = "4.3.1";
+    version = "4.3.3";
     dependencies = [ bitflags libc ];
-    sha256 = "0dgmgdmrfbjkpxn1w3xmmwsm2a623a9qdwn90s8yl78n4a36kbh9";
+    sha256 = "1wc8dsd0dhqgskmkwd82fzqsy2hg0wm3833jxhzxkrwcip25yr3a";
   };
 
   serde = buildRustCrate {
@@ -279,14 +289,12 @@ rec {
   pkg-config = buildRustCrate {
     pname = "pkg-config";
     version = "0.3.19";
-    crateName = "pkg_config";
     sha256 = "1kd047p8jv6mhmfzddjvfa2nwkfrb3l1wml6lfm51n1cr06cc9lz";
   };
 
   libz-sys = buildRustCrate {
     pname = "libz-sys";
     version = "1.1.2";
-    crateName = "libz-sys";
     sha256 = "1y7v6bkwr4b6yaf951p1ns7mx47b29ziwdd5wziaic14gs1gwq30";
     buildDependencies = [
       cc
@@ -296,9 +304,8 @@ rec {
 
   libgit2-sys = buildRustCrate {
     pname = "libgit2-sys";
-    version = "0.12.26+1.3.0";
-    crateName = "libgit2_sys";
-    sha256 = "15zg0yy7lk7464yf9i1kxh4gaxdyb8m96ayb7vkjgmz1s2rgq7s2";
+    version = "0.16.2+1.7.2";
+    sha256 = "0bs446idbmg8s13jvb0ck6qmrskcdn2mp3d4mn9ggxbmiw4ryd3g";
     dependencies = [
       libc
       libz-sys
@@ -313,20 +320,19 @@ rec {
       cc
       pkg-config
     ];
+    env.LIBGIT2_NO_VENDOR = "1";
   };
 
   matches = buildRustCrate {
     pname = "matches";
     version = "0.1.8";
-    crateName = "matches";
     sha256 = "03hl636fg6xggy0a26200xs74amk3k9n0908rga2szn68agyz3cv";
     libPath = "lib.rs";
   };
 
   percent-encoding = buildRustCrate {
-    pname = "percent_encoding";
+    pname = "percent-encoding";
     version = "2.1.0";
-    crateName = "percent_encoding";
     sha256 = "0i838f2nr81585ckmfymf8l1x1vdmx6n8xqvli0lgcy60yl2axy3";
     libPath = "lib.rs";
   };
@@ -334,7 +340,6 @@ rec {
   form_urlencoded = buildRustCrate {
     pname = "form_urlencoded";
     version = "1.0.1";
-    crateName = "form_urlencoded";
     sha256 = "0rhv2hfrzk2smdh27walkm66zlvccnnwrbd47fmf8jh6m420dhj8";
     dependencies = [
       matches
@@ -345,14 +350,12 @@ rec {
   tinyvec_macros = buildRustCrate {
     pname = "tinyvec_macros";
     version = "0.1.0";
-    crateName = "tinyvec-macros";
     sha256 = "0aim73hyq5g8b2hs9gjq2sv0xm4xzfbwp5fdyg1frljqzkapq682";
   };
 
   tinyvec = buildRustCrate {
     pname = "tinyvec";
     version = "1.2.0";
-    crateName = "tinyvec";
     sha256 = "1c95nma20kiyrjwfsk7hzd5ir6yy4bm63fmfbfb4dm9ahnlvdp3y";
     features = [ "alloc" ];
     dependencies = [
@@ -363,7 +366,6 @@ rec {
   unicode-normalization = buildRustCrate {
     pname = "unicode-normalization";
     version = "0.1.17";
-    crateName = "unicode_normalization";
     sha256 = "0w4s0avzlf7pzcclhhih93aap613398sshm6jrxcwq0f9lhis11c";
     dependencies = [
       tinyvec
@@ -373,7 +375,6 @@ rec {
   unicode-bidi = buildRustCrate {
     pname = "unicode-bidi";
     version = "0.3.5";
-    crateName = "unicode_bidi";
     sha256 = "193jzlxj1dfcms2381lyd45zh4ywlicj9lzcfpid1zbkmfarymkz";
     dependencies = [
       matches
@@ -383,7 +384,6 @@ rec {
   idna = buildRustCrate {
     pname = "idna";
     version = "0.2.3";
-    crateName = "idna";
     sha256 = "0hwypd0fpym9lmd4bbqpwyr5lhrlvmvzhi1vy9asc5wxwkzrh299";
     dependencies = [
       matches
@@ -395,7 +395,6 @@ rec {
   url = buildRustCrate {
     pname = "url";
     version = "2.2.1";
-    crateName = "url";
     sha256 = "1ci1djafh83qhpzbmxnr9w5gcrjs3ghf8rrxdy4vklqyji6fvn5v";
     dependencies = [
       form_urlencoded
@@ -409,9 +408,8 @@ rec {
   git2 = buildRustCrate {
     pname = "git2";
     edition = "2018";
-    version = "0.13.25";
-    crateName = "git2";
-    sha256 = "181mw4kxsqrwpib9kf25fykc48wxhjla37vzis4j0b0w0yhyaqi3";
+    version = "0.18.1";
+    sha256 = "1d1wm8cn37svyxgvzfapwilkkc9d2x7fcrgciwn8b2pv9aqz102k";
     dependencies = [
       bitflags
       libc