about summary refs log tree commit diff
path: root/third_party/nix/tests/lang/parse-fail-dup-attrs-2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/tests/lang/parse-fail-dup-attrs-2.nix')
-rw-r--r--third_party/nix/tests/lang/parse-fail-dup-attrs-2.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/third_party/nix/tests/lang/parse-fail-dup-attrs-2.nix b/third_party/nix/tests/lang/parse-fail-dup-attrs-2.nix
new file mode 100644
index 0000000000..864d9865e0
--- /dev/null
+++ b/third_party/nix/tests/lang/parse-fail-dup-attrs-2.nix
@@ -0,0 +1,13 @@
+let {
+
+  as = {
+    x = 123;
+    y = 456;
+  };
+
+  bs = {
+    x = 789;
+    inherit (as) x;
+  };
+  
+}