about summary refs log tree commit diff
path: root/third_party/nix/tests/lang/eval-okay-filter.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/tests/lang/eval-okay-filter.nix')
-rw-r--r--third_party/nix/tests/lang/eval-okay-filter.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/third_party/nix/tests/lang/eval-okay-filter.nix b/third_party/nix/tests/lang/eval-okay-filter.nix
new file mode 100644
index 0000000000..85109b0d0e
--- /dev/null
+++ b/third_party/nix/tests/lang/eval-okay-filter.nix
@@ -0,0 +1,5 @@
+with import ./lib.nix;
+
+builtins.filter
+  (x: x / 2 * 2 == x)
+  (builtins.concatLists [ (range 0 10) (range 100 110) ])