about summary refs log tree commit diff
path: root/third_party/nix/tests/lang/eval-fail-scope-5.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/tests/lang/eval-fail-scope-5.nix')
-rw-r--r--third_party/nix/tests/lang/eval-fail-scope-5.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/third_party/nix/tests/lang/eval-fail-scope-5.nix b/third_party/nix/tests/lang/eval-fail-scope-5.nix
new file mode 100644
index 0000000000..f89a65a99b
--- /dev/null
+++ b/third_party/nix/tests/lang/eval-fail-scope-5.nix
@@ -0,0 +1,10 @@
+let {
+
+  x = "a";
+  y = "b";
+
+  f = {x ? y, y ? x}: x + y;
+
+  body = f {};
+
+}