about summary refs log tree commit diff
path: root/third_party/nix/tests/gc-runtime.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/tests/gc-runtime.nix')
-rw-r--r--third_party/nix/tests/gc-runtime.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/third_party/nix/tests/gc-runtime.nix b/third_party/nix/tests/gc-runtime.nix
new file mode 100644
index 0000000000..ee5980bdff
--- /dev/null
+++ b/third_party/nix/tests/gc-runtime.nix
@@ -0,0 +1,17 @@
+with import ./config.nix;
+
+mkDerivation {
+  name = "gc-runtime";
+  builder =
+    # Test inline source file definitions.
+    builtins.toFile "builder.sh" ''
+      mkdir $out
+
+      cat > $out/program <<EOF
+      #! ${shell}
+      sleep 10000
+      EOF
+
+      chmod +x $out/program
+    '';
+}