about summary refs log tree commit diff
path: root/third_party/nix/tests/export-graph.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/tests/export-graph.nix')
-rw-r--r--third_party/nix/tests/export-graph.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/third_party/nix/tests/export-graph.nix b/third_party/nix/tests/export-graph.nix
deleted file mode 100644
index fdac9583db..0000000000
--- a/third_party/nix/tests/export-graph.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-with import ./config.nix;
-
-rec {
-
-  printRefs =
-    ''
-      echo $exportReferencesGraph
-      while read path; do
-          read drv
-          read nrRefs
-          echo "$path has $nrRefs references"
-          echo "$path" >> $out
-          for ((n = 0; n < $nrRefs; n++)); do read ref; echo "ref $ref"; test -e "$ref"; done
-      done < refs
-    '';
-
-  foo."bar.runtimeGraph" = mkDerivation {
-    name = "dependencies";
-    builder = builtins.toFile "build-graph-builder" "${printRefs}";
-    exportReferencesGraph = ["refs" (import ./dependencies.nix)];
-  };
-
-  foo."bar.buildGraph" = mkDerivation {
-    name = "dependencies";
-    builder = builtins.toFile "build-graph-builder" "${printRefs}";
-    exportReferencesGraph = ["refs" (import ./dependencies.nix).drvPath];
-  };
-
-}