about summary refs log tree commit diff
path: root/third_party/nix/tests/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/tests/config.nix')
-rw-r--r--third_party/nix/tests/config.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/third_party/nix/tests/config.nix b/third_party/nix/tests/config.nix
deleted file mode 100644
index 6ba91065b8..0000000000
--- a/third_party/nix/tests/config.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-with import <nix/config.nix>;
-
-rec {
-  inherit shell;
-
-  path = coreutils;
-
-  system = builtins.currentSystem;
-
-  shared = builtins.getEnv "_NIX_TEST_SHARED";
-
-  mkDerivation = args:
-    derivation ({
-      inherit system;
-      builder = shell;
-      args = ["-e" args.builder or (builtins.toFile "builder.sh" "if [ -e .attrs.sh ]; then source .attrs.sh; fi; eval \"$buildCommand\"")];
-      PATH = path;
-    } // removeAttrs args ["builder" "meta"])
-    // { meta = args.meta or {}; };
-}