about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-types.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-types.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-types.nix b/third_party/nix/src/tests/lang/eval-okay-types.nix
deleted file mode 100644
index cc51d8cb7a..0000000000
--- a/third_party/nix/src/tests/lang/eval-okay-types.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-with builtins;
-
-[ (isNull null)
-  (isNull (x: x))
-  (isFunction (x: x))
-  (isFunction functionArgs)
-  (isFunction "fnord")
-  (isString ("foo" + "bar"))
-  (isString [ "x" ])
-  (isInt (1 + 2))
-  (isInt { x = 123; })
-  (isInt (1 / 2))
-  (isInt (1 + 1))
-  (isInt (1 / 2))
-  (isInt (1 * 2))
-  (isInt (1 - 2))
-  (isFloat (1.2))
-  (isFloat (1 + 1.0))
-  (isFloat (1 / 2.0))
-  (isFloat (1 * 2.0))
-  (isFloat (1 - 2.0))
-  (isBool (true && false))
-  (isBool null)
-  (isPath /nix/store)
-  (isPath ./.)
-  (isAttrs { x = 123; })
-  (isAttrs null)
-  (typeOf (3 * 4))
-  (typeOf true)
-  (typeOf "xyzzy")
-  (typeOf null)
-  (typeOf { x = 456; })
-  (typeOf [ 1 2 3 ])
-  (typeOf (x: x))
-  (typeOf ((x: y: x) 1))
-  (typeOf map)
-  (typeOf (map (x: x)))
-]