about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix b/third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix
deleted file mode 100644
index 5e40928dbe..0000000000
--- a/third_party/nix/src/tests/lang/eval-okay-strings-as-attrs-names.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-let
-
-  attr = {
-    "key 1" = "test";
-    "key 2" = "caseok";
-  };
-
-  t1 = builtins.getAttr "key 1" attr;
-  t2 = attr."key 2";
-  t3 = attr ? "key 1";
-  t4 = builtins.attrNames { inherit (attr) "key 1"; };
-
-  # This is permitted, but there is currently no way to reference this
-  # variable.
-  "foo bar" = 1;
-
-in t1 == "test"
-   && t2 == "caseok"
-   && t3 == true
-   && t4 == ["key 1"]