about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix11
1 files changed, 0 insertions, 11 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix b/third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix
deleted file mode 100644
index 4186e029b5..0000000000
--- a/third_party/nix/src/tests/lang/eval-okay-listtoattrs.nix
+++ /dev/null
@@ -1,11 +0,0 @@
-# this test shows how to use listToAttrs and that evaluation is still lazy (throw isn't called)
-with import ./lib.nix;
-
-let 
-  asi = name: value : { inherit name value; };
-  list = [ ( asi "a" "A" ) ( asi "b" "B" ) ];
-  a = builtins.listToAttrs list;
-  b = builtins.listToAttrs ( list ++ list );
-  r = builtins.listToAttrs [ (asi "result" [ a b ]) ( asi "throw" (throw "this should not be thrown")) ];
-  x = builtins.listToAttrs [ (asi "foo" "bar") (asi "foo" "bla") ];
-in concat (map (x: x.a) r.result) + x.foo