about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/eval-okay-closure.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/src/tests/lang/eval-okay-closure.nix')
-rw-r--r--third_party/nix/src/tests/lang/eval-okay-closure.nix13
1 files changed, 0 insertions, 13 deletions
diff --git a/third_party/nix/src/tests/lang/eval-okay-closure.nix b/third_party/nix/src/tests/lang/eval-okay-closure.nix
deleted file mode 100644
index cccd4dc357..0000000000
--- a/third_party/nix/src/tests/lang/eval-okay-closure.nix
+++ /dev/null
@@ -1,13 +0,0 @@
-let
-
-  closure = builtins.genericClosure {
-    startSet = [{key = 80;}];
-    operator = {key, foo ? false}:
-      if builtins.lessThan key 0
-      then []
-      else [{key = builtins.sub key 9;} {key = builtins.sub key 13; foo = true;}];
-  };
-
-  sort = (import ./lib.nix).sortBy (a: b: builtins.lessThan a.key b.key);
-
-in sort closure