about summary refs log tree commit diff
path: root/third_party/nix/src/nix-daemon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/src/nix-daemon/CMakeLists.txt')
-rw-r--r--third_party/nix/src/nix-daemon/CMakeLists.txt29
1 files changed, 0 insertions, 29 deletions
diff --git a/third_party/nix/src/nix-daemon/CMakeLists.txt b/third_party/nix/src/nix-daemon/CMakeLists.txt
deleted file mode 100644
index 63125a9b26..0000000000
--- a/third_party/nix/src/nix-daemon/CMakeLists.txt
+++ /dev/null
@@ -1,29 +0,0 @@
-# -*- mode: cmake; -*-
-
-# The nix-daemon is the binary running the gRPC server component to
-# which other components of Nix talk to perform store and builder
-# operations.
-
-add_executable(nix-daemon)
-include_directories(${PROJECT_BINARY_DIR}) # for config.h
-set_property(TARGET nix-daemon PROPERTY CXX_STANDARD 17)
-
-pkg_check_modules(systemd REQUIRED)
-
-target_sources(nix-daemon
-  PRIVATE
-    nix-daemon-proto.hh
-    nix-daemon-proto.cc
-    nix-daemon.cc
-)
-
-target_link_libraries(nix-daemon
-  nixutil
-  nixstore
-  nixmain
-  absl::flags
-  absl::flags_parse
-  systemd
-)
-
-install(TARGETS nix-daemon DESTINATION bin)