about summary refs log tree commit diff
path: root/third_party/nix/src/libstore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/src/libstore/CMakeLists.txt')
-rw-r--r--third_party/nix/src/libstore/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/third_party/nix/src/libstore/CMakeLists.txt b/third_party/nix/src/libstore/CMakeLists.txt
index 21adb0fb02..a7b0ea60ff 100644
--- a/third_party/nix/src/libstore/CMakeLists.txt
+++ b/third_party/nix/src/libstore/CMakeLists.txt
@@ -19,8 +19,7 @@ string(CONFIGURE
 
 file(WRITE ${PROJECT_BINARY_DIR}/generated/schema.sql.hh ${NIX_SCHEMA_GEN})
 
-target_sources(nixstore
-  PUBLIC
+set(HEADER_FILES
     binary-cache-store.hh
     builtins.hh
     crypto.hh
@@ -46,6 +45,11 @@ target_sources(nixstore
     ssh.hh
     store-api.hh
     worker-protocol.hh
+)
+
+target_sources(nixstore
+  PUBLIC
+    ${HEADER_FILES}
 
   PRIVATE
     ${PROJECT_BINARY_DIR}/generated/schema.sql.hh
@@ -99,4 +103,5 @@ target_link_libraries(nixstore
   sodium
 )
 
+INSTALL(FILES ${HEADER_FILES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/nix/libstore)
 INSTALL(TARGETS nixstore DESTINATION lib)