about summary refs log tree commit diff
path: root/third_party/nix/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/shell.nix')
-rw-r--r--third_party/nix/shell.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/third_party/nix/shell.nix b/third_party/nix/shell.nix
index e8026f8e40..e163fccf9c 100644
--- a/third_party/nix/shell.nix
+++ b/third_party/nix/shell.nix
@@ -1,10 +1,9 @@
-{ useClang ? false }:
-
-with import (builtins.fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-19.03.tar.gz) {};
+let pkgs = (import <nixpkgs> {}).third_party;
+in with pkgs;
 
 with import ./release-common.nix { inherit pkgs; };
 
-(if useClang then clangStdenv else stdenv).mkDerivation {
+clangStdenv.mkDerivation {
   name = "nix";
 
   buildInputs = buildDeps ++ propagatedDeps ++ tarballDeps ++ perlDeps;