about summary refs log tree commit diff
path: root/third_party/nix/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/shell.nix')
-rw-r--r--third_party/nix/shell.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/nix/shell.nix b/third_party/nix/shell.nix
new file mode 100644
index 0000000000..e8026f8e40
--- /dev/null
+++ b/third_party/nix/shell.nix
@@ -0,0 +1,25 @@
+{ useClang ? false }:
+
+with import (builtins.fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-19.03.tar.gz) {};
+
+with import ./release-common.nix { inherit pkgs; };
+
+(if useClang then clangStdenv else stdenv).mkDerivation {
+  name = "nix";
+
+  buildInputs = buildDeps ++ propagatedDeps ++ tarballDeps ++ perlDeps;
+
+  inherit configureFlags;
+
+  enableParallelBuilding = true;
+
+  installFlags = "sysconfdir=$(out)/etc";
+
+  shellHook =
+    ''
+      export prefix=$(pwd)/inst
+      configureFlags+=" --prefix=$prefix"
+      PKG_CONFIG_PATH=$prefix/lib/pkgconfig:$PKG_CONFIG_PATH
+      PATH=$prefix/bin:$PATH
+    '';
+}