about summary refs log tree commit diff
path: root/third_party/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/default.nix')
-rw-r--r--third_party/nix/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/third_party/nix/default.nix b/third_party/nix/default.nix
index c31de41edd..e6fa3f1f7d 100644
--- a/third_party/nix/default.nix
+++ b/third_party/nix/default.nix
@@ -36,13 +36,11 @@ in pkgs.llvmPackages.libcxxStdenv.mkDerivation {
  # TODO(tazjin): Some of these might only be required for native inputs
   buildInputs = with pkgs; [
     aws-s3-cpp
-    boost
     brotli
     bzip2
     curl
     editline
     flex
-    largeBoehm
     libseccomp
     libsodium
     openssl
@@ -50,6 +48,11 @@ in pkgs.llvmPackages.libcxxStdenv.mkDerivation {
     xz
   ];
 
+  propagatedBuildInputs = with pkgs; [
+    boost
+    largeBoehm
+  ];
+
   # Install the various symlinks to the Nix binary which users expect
   # to exist.
   postInstall = ''