about summary refs log tree commit diff
path: root/third_party/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/default.nix')
-rw-r--r--third_party/nix/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/third_party/nix/default.nix b/third_party/nix/default.nix
index e6fa3f1f7d..1a4e4bae08 100644
--- a/third_party/nix/default.nix
+++ b/third_party/nix/default.nix
@@ -48,11 +48,24 @@ in pkgs.llvmPackages.libcxxStdenv.mkDerivation {
     xz
   ];
 
+  installCheckInputs = with pkgs; [
+    utillinux
+  ];
+
   propagatedBuildInputs = with pkgs; [
     boost
     largeBoehm
   ];
 
+  doInstallCheck = true;
+
+  installCheckPhase = ''
+    export PATH=$out/bin:$PATH
+    cd ../tests/
+    substituteAll common.sh.in common.sh
+    bash lang.sh
+  '';
+
   # Install the various symlinks to the Nix binary which users expect
   # to exist.
   postInstall = ''