about summary refs log tree commit diff
path: root/third_party/nix/corepkgs/fetchurl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/corepkgs/fetchurl.nix')
-rw-r--r--third_party/nix/corepkgs/fetchurl.nix19
1 files changed, 12 insertions, 7 deletions
diff --git a/third_party/nix/corepkgs/fetchurl.nix b/third_party/nix/corepkgs/fetchurl.nix
index a84777f574..9933b7cc12 100644
--- a/third_party/nix/corepkgs/fetchurl.nix
+++ b/third_party/nix/corepkgs/fetchurl.nix
@@ -2,12 +2,13 @@
 , url
 , hash ? "" # an SRI ash
 
-# Legacy hash specification
-, md5 ? "", sha1 ? "", sha256 ? "", sha512 ? ""
-, outputHash ?
-    if hash != "" then hash else if sha512 != "" then sha512 else if sha1 != "" then sha1 else if md5 != "" then md5 else sha256
-, outputHashAlgo ?
-    if hash != "" then "" else if sha512 != "" then "sha512" else if sha1 != "" then "sha1" else if md5 != "" then "md5" else "sha256"
+  # Legacy hash specification
+, md5 ? ""
+, sha1 ? ""
+, sha256 ? ""
+, sha512 ? ""
+, outputHash ? if hash != "" then hash else if sha512 != "" then sha512 else if sha1 != "" then sha1 else if md5 != "" then md5 else sha256
+, outputHashAlgo ? if hash != "" then "" else if sha512 != "" then "sha512" else if sha1 != "" then "sha1" else if md5 != "" then "md5" else "sha256"
 
 , executable ? false
 , unpack ? false
@@ -33,7 +34,11 @@ derivation {
     # easy proxy configuration.  This is impure, but a fixed-output
     # derivation like fetchurl is allowed to do so since its result is
     # by definition pure.
-    "http_proxy" "https_proxy" "ftp_proxy" "all_proxy" "no_proxy"
+    "http_proxy"
+    "https_proxy"
+    "ftp_proxy"
+    "all_proxy"
+    "no_proxy"
   ];
 
   # To make "nix-prefetch-url" work.