about summary refs log tree commit diff
path: root/third_party/nix/corepkgs/derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/corepkgs/derivation.nix')
-rw-r--r--third_party/nix/corepkgs/derivation.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/third_party/nix/corepkgs/derivation.nix b/third_party/nix/corepkgs/derivation.nix
deleted file mode 100644
index 1f95cf88ec..0000000000
--- a/third_party/nix/corepkgs/derivation.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-/* This is the implementation of the ‘derivation’ builtin function.
-   It's actually a wrapper around the ‘derivationStrict’ primop. */
-
-drvAttrs @ { outputs ? [ "out" ], ... }:
-
-let
-
-  strict = derivationStrict drvAttrs;
-
-  commonAttrs = drvAttrs // (builtins.listToAttrs outputsList) //
-    {
-      all = map (x: x.value) outputsList;
-      inherit drvAttrs;
-    };
-
-  outputToAttrListElement = outputName:
-    {
-      name = outputName;
-      value = commonAttrs // {
-        outPath = builtins.getAttr outputName strict;
-        drvPath = strict.drvPath;
-        type = "derivation";
-        inherit outputName;
-      };
-    };
-
-  outputsList = map outputToAttrListElement outputs;
-
-in
-(builtins.head outputsList).value