about summary refs log tree commit diff
path: root/third_party/nix/corepkgs/config.nix.in
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/corepkgs/config.nix.in')
-rw-r--r--third_party/nix/corepkgs/config.nix.in29
1 files changed, 0 insertions, 29 deletions
diff --git a/third_party/nix/corepkgs/config.nix.in b/third_party/nix/corepkgs/config.nix.in
deleted file mode 100644
index 0e4a2f0c90..0000000000
--- a/third_party/nix/corepkgs/config.nix.in
+++ /dev/null
@@ -1,29 +0,0 @@
-let
-  fromEnv = var: def:
-    let val = builtins.getEnv var; in
-    if val != "" then val else def;
-in rec {
-  shell = "@bash@";
-  coreutils = "@coreutils@";
-  bzip2 = "@bzip2@";
-  gzip = "@gzip@";
-  xz = "@xz@";
-  tar = "@tar@";
-  tarFlags = "@tarFlags@";
-  tr = "@tr@";
-  nixBinDir = fromEnv "NIX_BIN_DIR" "@CMAKE_INSTALL_FULL_BINDIR@";
-  nixPrefix = "@CMAKE_INSTALL_PREFIX@";
-  nixLibexecDir = fromEnv "NIX_LIBEXEC_DIR" "@CMAKE_INSTALL_FULL_LIBEXECDIR@";
-  nixLocalstateDir = "/nix/var";
-  nixSysconfDir = "/etc";
-  nixStoreDir = fromEnv "NIX_STORE_DIR" "/nix/store";
-
-  # If Nix is installed in the Nix store, then automatically add it as
-  # a dependency to the core packages. This ensures that they work
-  # properly in a chroot.
-  chrootDeps =
-    if dirOf nixPrefix == builtins.storeDir then
-      [ (builtins.storePath nixPrefix) ]
-    else
-      [ ];
-}