about summary refs log tree commit diff
path: root/third_party/nix/clangd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/clangd.nix')
-rw-r--r--third_party/nix/clangd.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/third_party/nix/clangd.nix b/third_party/nix/clangd.nix
deleted file mode 100644
index 7a29819b10..0000000000
--- a/third_party/nix/clangd.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-# Create a clangd wrapper script that can be used with this project.
-# The default Nix wrapper only works with C projects, not C++
-# projects.
-#
-# The CPATH construction logic is lifted from the original wrapper
-# script.
-
-pkgs:
-
-pkgs.writeShellScriptBin "nix-clangd" ''
-  buildcpath() {
-    local path
-    while (( $# )); do
-      case $1 in
-          -isystem)
-              shift
-              path=$path''${path:+':'}$1
-      esac
-      shift
-    done
-    echo $path
-  }
-
-  export CPATH=''${CPATH}''${CPATH:+':'}:$(buildcpath ''${NIX_CFLAGS_COMPILE})
-  export CPATH=${pkgs.glibc.dev}/include''${CPATH:+':'}''${CPATH}
-  export CPLUS_INCLUDE_PATH=${pkgs.llvmPackages_11.libcxx}/include/c++/v1:''${CPATH}
-
-  # TODO(tazjin): Configurable commands directory?
-  exec -a clangd ${pkgs.llvmPackages_11.clang-unwrapped}/bin/clangd -cross-file-rename $@
-''