about summary refs log tree commit diff
path: root/third_party/nix/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/CMakeLists.txt')
-rw-r--r--third_party/nix/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/third_party/nix/CMakeLists.txt b/third_party/nix/CMakeLists.txt
index 54bf362332..fad650a7ca 100644
--- a/third_party/nix/CMakeLists.txt
+++ b/third_party/nix/CMakeLists.txt
@@ -30,6 +30,14 @@ find_package(LibLZMA)
 # builds this symlink is automatically replaced with an appropriate
 # link to the Abseil sources in the Nix store.
 add_subdirectory(abseil_cpp)
+install(DIRECTORY abseil_cpp/absl
+  DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+  FILES_MATCHING
+    PATTERN "*.inc"
+    PATTERN "*.h"
+    PATTERN "copts" EXCLUDE
+    PATTERN "testdata" EXCLUDE
+  )
 
 # Linking precompiled glog binaries (linked against libstdc++) leads
 # to working binaries that do not output log messages. It seems that