about summary refs log tree commit diff
path: root/third_party/lisp/usocket.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/usocket.nix')
-rw-r--r--third_party/lisp/usocket.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/third_party/lisp/usocket.nix b/third_party/lisp/usocket.nix
index 0f40ab64aa..920c41c58d 100644
--- a/third_party/lisp/usocket.nix
+++ b/third_party/lisp/usocket.nix
@@ -1,9 +1,9 @@
 # Usocket is a portable socket library
-{ pkgs, ... }:
+{ depot, ... }:
 
-with pkgs.nix;
+with depot.nix;
 
-let src = pkgs.third_party.fetchFromGitHub {
+let src = depot.third_party.fetchFromGitHub {
   owner = "usocket";
   repo = "usocket";
   rev = "fdf4fd1e0051ce83340ccfbbc8a43a462bb19cf2";
@@ -11,7 +11,7 @@ let src = pkgs.third_party.fetchFromGitHub {
 };
 in buildLisp.library {
   name = "usocket";
-  deps = with pkgs.third_party.lisp; [
+  deps = with depot.third_party.lisp; [
     (buildLisp.bundled "asdf")
     (buildLisp.bundled "sb-bsd-sockets")
     split-sequence