about summary refs log tree commit diff
path: root/third_party/lisp/usocket-server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/usocket-server.nix')
-rw-r--r--third_party/lisp/usocket-server.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/third_party/lisp/usocket-server.nix b/third_party/lisp/usocket-server.nix
new file mode 100644
index 0000000000..5d6d04535f
--- /dev/null
+++ b/third_party/lisp/usocket-server.nix
@@ -0,0 +1,19 @@
+# Universal socket library for Common Lisp (server side)
+{ depot, pkgs, ... }:
+
+let
+  inherit (depot.nix) buildLisp;
+  src = with pkgs; srcOnly lispPackages.usocket-server;
+in
+buildLisp.library {
+  name = "usocket-server";
+
+  deps = with depot.third_party.lisp; [
+    usocket
+    bordeaux-threads
+  ];
+
+  srcs = [
+    "${src}/server.lisp"
+  ];
+}