about summary refs log tree commit diff
path: root/third_party/lisp/puri.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/puri.nix')
-rw-r--r--third_party/lisp/puri.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/third_party/lisp/puri.nix b/third_party/lisp/puri.nix
index 51728c7646..f7146ba93f 100644
--- a/third_party/lisp/puri.nix
+++ b/third_party/lisp/puri.nix
@@ -1,15 +1,10 @@
 # Portable URI library
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-let src = builtins.fetchGit {
-  url = "http://git.kpe.io/puri.git";
-  rev = "ef5afb9e5286c8e952d4344f019c1a636a717b97";
-};
+let src = with pkgs; srcOnly lispPackages.puri;
 in depot.nix.buildLisp.library {
   name = "puri";
   srcs = [
     (src + "/src.lisp")
   ];
 }
-
-