about summary refs log tree commit diff
path: root/third_party/lisp/md5.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/md5.nix')
-rw-r--r--third_party/lisp/md5.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/third_party/lisp/md5.nix b/third_party/lisp/md5.nix
new file mode 100644
index 0000000000..3787e23175
--- /dev/null
+++ b/third_party/lisp/md5.nix
@@ -0,0 +1,18 @@
+# MD5 hash implementation
+{ pkgs, ... }:
+
+let src = pkgs.third_party.fetchFromGitHub {
+  owner = "pmai";
+  repo = "md5";
+  rev = "b1412600f60d526ee34a7ba1596ec483da7894ab";
+  sha256 = "0lzip6b6xg7gd70xl1xmqp24fvxqj6ywjnz9lmx7988zpj20nhl2";
+};
+in pkgs.nix.buildLisp.library {
+  name = "md5";
+
+  deps = with pkgs.third_party.lisp; [
+    sb-rotate-byte
+  ];
+
+  srcs = [ (src + "/md5.lisp") ];
+}