about summary refs log tree commit diff
path: root/third_party/lisp/lisp-binary.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/lisp-binary.nix')
-rw-r--r--third_party/lisp/lisp-binary.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/third_party/lisp/lisp-binary.nix b/third_party/lisp/lisp-binary.nix
new file mode 100644
index 0000000000..6f340bfab9
--- /dev/null
+++ b/third_party/lisp/lisp-binary.nix
@@ -0,0 +1,30 @@
+# A library to easily read and write complex binary formats.
+{ pkgs, ... }:
+
+let src = pkgs.third_party.fetchFromGitHub {
+  owner = "j3pic";
+  repo = "lisp-binary";
+  rev = "1aefc8618b7734f68697ddf59bc93cb8522aa0bf";
+  sha256 = "1hflzn3mjp32jz9fxx9wayp3c3x58s77cgjfbs06nrynqkv0c6df";
+};
+in pkgs.nix.buildLisp.library {
+  name = "lisp-binary";
+
+  deps = with pkgs.third_party.lisp; [
+    cffi
+    quasiquote_2
+    moptilities
+    flexi-streams
+    closer-mop
+  ];
+
+  srcs = map (f: src + ("/" + f)) [
+    "utils.lisp"
+    "integer.lisp"
+    "float.lisp"
+    "simple-bit-stream.lisp"
+    "reverse-stream.lisp"
+    "binary-1.lisp"
+    "binary-2.lisp"
+  ];
+}