about summary refs log tree commit diff
path: root/third_party/lisp/hunchentoot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/hunchentoot.nix')
-rw-r--r--third_party/lisp/hunchentoot.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/third_party/lisp/hunchentoot.nix b/third_party/lisp/hunchentoot.nix
index 9977405c65..e2480cd349 100644
--- a/third_party/lisp/hunchentoot.nix
+++ b/third_party/lisp/hunchentoot.nix
@@ -1,13 +1,9 @@
 # Hunchentoot is a web framework for Common Lisp.
-{ depot, ...}:
+{ depot, pkgs, ... }:
 
 let
-  src = depot.third_party.fetchFromGitHub {
-    owner = "edicl";
-    repo = "hunchentoot";
-    rev = "585b45b6b873f2da421fdf456b61860ab5868207";
-    sha256 = "13nazwix067mdclq9vgjhsi2vpr57a8dz51dd5d3h99ccsq4mik5";
-  };
+  src = with pkgs; srcOnly lispPackages.hunchentoot;
+
   url-rewrite = depot.nix.buildLisp.library {
     name = "url-rewrite";
 
@@ -19,7 +15,8 @@ let
       "url-rewrite.lisp"
     ];
   };
-in depot.nix.buildLisp.library {
+in
+depot.nix.buildLisp.library {
   name = "hunchentoot";
 
   deps = with depot.third_party.lisp; [
@@ -58,4 +55,8 @@ in depot.nix.buildLisp.library {
     "acceptor.lisp"
     "easy-handlers.lisp"
   ];
+
+  brokenOn = [
+    "ecl" # dynamic cffi
+  ];
 }